Frequency Community Forum

Welcome to our community. We have one rule: Be excellent to each other.

Sierra Wireless EM7565 pppd chatscript

Anyone have a working pppd connection with the EM7565? It appears to connect however no IPCP exchanges occur…

This is what I am seeing:

root@openwebrx:/etc/chatscripts# pon
pppd options in effect:
debug # (from /etc/ppp/peers/provider)
nodetach # (from /etc/ppp/peers/provider)
persist # (from /etc/ppp/peers/provider)
dump # (from /etc/ppp/peers/provider)
noauth # (from /etc/ppp/peers/provider)
remotename 3gppp # (from /etc/ppp/peers/provider)
/dev/ttyUSB2 # (from /etc/ppp/peers/provider)
115200 # (from /etc/ppp/peers/provider)
lock # (from /etc/ppp/peers/provider)
connect chat -s -v -f /etc/chatscripts/chat-connect -T celona # (from /etc/ppp/peers/provider)
disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
crtscts # (from /etc/ppp/peers/provider)
modem # (from /etc/ppp/peers/provider)
asyncmap 0 # (from /etc/ppp/options)
mru 1440 # (from /etc/ppp/peers/provider)
lcp-echo-failure 4 # (from /etc/ppp/options)
lcp-echo-interval 30 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/peers/provider)
novj # (from /etc/ppp/peers/provider)
novjccomp # (from /etc/ppp/peers/provider)
ipcp-accept-local # (from /etc/ppp/peers/provider)
ipcp-accept-remote # (from /etc/ppp/peers/provider)
ipparam 3gppp # (from /etc/ppp/peers/provider)
noipdefault # (from /etc/ppp/peers/provider)
ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
defaultroute # (from /etc/ppp/peers/provider)
usepeerdns # (from /etc/ppp/peers/provider)
: # (from /etc/ppp/peers/provider)
noccp # (from /etc/ppp/peers/provider)
noipx # (from /etc/ppp/options)
abort on (BUSY)
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (ERROR)
abort on (NO ANSWER)
timeout set to 30 seconds
send (AT^M)
expect (OK)
^M
OK
– got it

send (ATE0^M)
expect (OK)
^M
^M
OK
– got it

send (AT!GSTATUS?^M)
expect (OK)
^M
^M
!GSTATUS: ^M
Current Time: 9606 Temperature: 28^M
Reset Counter: 1 Mode: ONLINE ^M
System mode: LTE PS state: Not attached ^M
LTE band: B41 LTE bw: 20 MHz ^M
LTE Rx chan: 41094 LTE Tx chan: 41094^M
LTE SSC1 state:NOT ASSIGNED^M
LTE SSC2 state:NOT ASSIGNED^M
LTE SSC3 state:NOT ASSIGNED^M
LTE SSC4 state:NOT ASSIGNED^M
EMM state: Deregistered Attach Needed ^M
RRC state: RRC Idle ^M
IMS reg state: No Srv ^M
^M
PCC RxM RSSI: -89 PCC RxM RSRP: -123^M
PCC RxD RSSI: -86 PCC RxD RSRP: -119^M
Tx Power: – TAC: aa04 (43524)^M
RSRQ (dB): -13.1 Cell ID: 09b6d700 (162977536)^M
SINR (dB): -1.8^M
^M
^M
OK
– got it

send (AT+CMEE=2^M)
expect (OK)
^M
^M
OK
– got it

send (AT+CGDCONT=1,“IP”,“celona”,“0.0.0.0”,0,0^M)
expect (OK)
^M
^M
OK
– got it

send (AT+CGQREQ=1,0,0,0,0,0^M)
expect (OK)
^M
^M
OK
– got it

send (AT+CGQMIN=1,0,0,0,0,0^M)
expect (OK)
^M
^M
OK
– got it

send (ATD99**1#^M)
expect (CONNECT)
^M
^M
CONNECT
– got it

Script chat -s -v -f /etc/chatscripts/chat-connect -T celona finished (pid 2644), status = 0x0
Serial connection established.
using channel 49
Using interface ppp0
Connect: ppp0 <–> /dev/ttyUSB2
sent [LCP ConfReq id=0x1 <mru 1440> <asyncmap 0x0> <magic 0xe6261dcc> ]
rcvd [LCP ConfReq id=0x90 <asyncmap 0x0> <magic 0xd18836df> ]
No auth is possible
sent [LCP ConfRej id=0x90 ]
rcvd [LCP ConfAck id=0x1 <mru 1440> <asyncmap 0x0> <magic 0xe6261dcc> ]
rcvd [LCP ConfReq id=0x91 <asyncmap 0x0> <magic 0xd18836df> ]
sent [LCP ConfAck id=0x91 <asyncmap 0x0> <magic 0xd18836df> ]
sent [LCP EchoReq id=0x0 magic=0xe6261dcc]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP DiscReq id=0x92 magic=0xd18836df]
rcvd [LCP EchoRep id=0x0 magic=0xd18836df e6 26 1d cc]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [LCP EchoReq id=0x1 magic=0xe6261dcc]
IPCP: timeout sending Config-Requests
sent [LCP TermReq id=0x2 “No network protocols running”]
sent [LCP TermReq id=0x3 “No network protocols running”]
Connection terminated.
abort on (ERROR)
abort on (NO DIALTONE)

Sending break to the modem
send (+++^M)
send (+++^M)
send (+++^M)

Goodbye
Script chat -s -v -f /etc/chatscripts/chat-disconnect finished (pid 2655), status = 0x0
Serial link disconnected.
Modem hangup